Designinglives

June 23, 2017 at 5:24 pm

Mcrypt PHP extension required

During my Laravel install I had some issues using the terminal, they all turned out to be linked to one issue:

Mcrypt PHP extension required

To solve this we need to open the bashrc file again which we also used during our install. Add the following line at the bottom of the script, this will ensure the use of AMPPS php, you can also use the MAMP path if wanted. Save the file (ctrl+x) and make sure the file is loaded again.

nano ~/.bashrc
export PATH="/Applications/AMPPS/php/bin:$PATH"
source ~/.bashrc

Now change directory to the one where your current install is located in and run the following command. If successful “Laravel Framework version x.x.xx” should be the output. If the problem still persists you probably still need to open up AMPPS stop all servers and turn on the PHP extension Mcrypt.

php artisan -V

Another issue which occurred during the creation of a laravel 5 (still in dev) was the following, which can also be solved by adding another extension to our php install called ctype.

Call to undefined function Composer\Package\Loader\ctype_digit()

0 likes error , installation , laravel 5
Share: / / /